Increased error rates
Incident Report for Robocorp
Resolved
The root cause has been fixed by AWS and our services have been back to stable since around 3 PM PDT (Oct 5) / 01:00 EEST (Oct 6).
Posted Oct 06, 2021 - 07:00 UTC
Identified
This situation is still active with a minor practical impact on users.

Our hosting provider AWS has confirmed increased invoke timeout rates in AWS Lambda. We expect the root cause to be solved by AWS in a timely fashion. Throughout the day we have implemented some resiliency improvements to the core services powering our platform.

Meanwhile, we continue to monitor the situation closely and are prepared to perform additional resiliency improvements as opportunities are identified.
Posted Oct 05, 2021 - 16:45 UTC
Investigating
We are currently observing slightly increased error rates around a database in our monitoring.

Recovery from most errors happens automatically and overall the platform is operating as usual.

However, if you are encountering any unusual problems please contact us via support@robocorp.com.
Posted Oct 05, 2021 - 08:20 UTC
This incident affected: Robots and API.